Intermittent Service due to Regional AWS Outage
Incident Report for Crisis Text Line
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 20:52 UTC
Investigating
We are currently investigating this issue.
Posted Jun 13, 2023 - 20:02 UTC
This incident affected: Platform (by region) (United States).